Home > スポンサー広告 > 「Da Mages Requirements」装備条件が付くMOD

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

Comments:-

一通 URL 2009-10-26 (月) 17:42

初めまして、いつも記事を参考にさせてもらっています。
修正パッチ頂きました。ありがたく使わせてもらいます。

Requirementsは好きなMODなんですが、ただの服が軽装扱いらしいのが玉に瑕なんですよね……自分はRealistic Levelingと併用してるのですが、新キャラで始めたらいきなり服をひん剥かれて笑ってしまいました。
他にもメイジなのに召喚武具がスキル不足で使えなかったりとかちょっとした不満があったりします。
まぁそれでも強力な武具が使えるようになった時の感動があるので、自分で手を加えてスクリプトの容量と格闘してますw

Airscape URL 2009-10-26 (月) 20:40

一通さん初めまして。
どうもエンチャントが付いていると必要Skillが一律で+10されるために、エンチャント衣服にもLight Armor Skillが必要になってしまうみたいですね。
そういった物や召喚武具は制限から除外できるといいんですが、現在のScriptが限界ぎりぎりのサイズなので条件式を増やすのが難しい感じですよね。後は装備が解除される時のメッセージをもっと簡略化して容量を減らすくらいでしょうか。

Comment Form

Trackback+Pingback:-

TrackBack URL for this entry
http://oblivionclarity.blog21.fc2.com/tb.php/128-9a168799
Listed below are links to weblogs that reference
スポンサーサイト from Oblivion Clarity

Home > スポンサー広告 > 「Da Mages Requirements」装備条件が付くMOD

Home > MOD紹介 > 「Da Mages Requirements」装備条件が付くMOD

「Da Mages Requirements」装備条件が付くMOD

[2009/10/25追記:Arena服などの一体型の装備で必要値が正しく計算されないバグ、必要値が足りないメッセージが何度も表示されるバグを修正したパッチを作成しました]

武具の装備に条件が付くMOD「Da Mages Requirements」の紹介です。要OBSE v0015以上。

ファンタジー系ゲームではよく、魔法使いのキャラは重い鎧を装備できないなどの装備条件があります。これによって非力な魔法系キャラが強力な武具を装備して魔法・近接OKの万能になるのを防いだり、戦士系・魔法系などキャラの特徴が失われないようにしてくれます。

Oblivionにも戦士・魔法使いといったクラスはありますが、あくまで初期のSkill値の違いと経験値の上がりやすさに影響があるだけで、どのクラスを選んでも装備の制限はありません。

Da Mages Requirementsでは、重い武器を振るうためにはStrengthが必要になったり、強力な武具を使いこなすためにそれに見合うSkill熟練度が必要になったりと装備条件が付くようになります。

Requirements Need Stats
装備条件に達していない武具を装備しようとすると、必要なAttribute・Skillが左上に表示され、装備が解除されます。

これによってキャラの苦手分野の装備が自然に制限され、Armor系Skillを育てていない魔法使いキャラはローブなどの装備を身につける必要性が出てきます。

強力な武具はステータスを上げないと装備できないため、そうした強力な武具を装備するためにAttribute・Skill熟練度を上げる楽しみも生まれます。

Da Mages Requirements v1.4のバグ修正パッチ


DM Requirements v1.4は、Arena・Dark Brotherfoodの装備などUpper/Lower/Hand/Footの部位を使う一体型の装備で必要値が正しく計算されず必要条件が跳ね上がるバグ、ゲーム画面で装備が解除された後に必要値のメッセージが何度も表示されるバグがあります。

これらを修正するパッチを作成したのでよければ使ってください。

DMRequirements V1.4 Fix Patch v1.0

Attribute・Skill熟練度による装備条件


Requirementsで必要になる条件はAttribute・Skillです。Skillは武具の攻撃力・防御力から計算され、そこからSkill熟練度と同じく5段階(0/25/50/75/100)に必要値が分けられます。

これにより武具Skillの熟練度が新たなSkill能力の会得だけでなく、より強力な武具を装備するためのアンロックとしての意味を持ちます。

Vanillaの最強装備であるDaedric系でも必要Skill値は75止まりですが、Daedricを凌ぐほどの強力武具を装備する場合にはSkill 100が必要になります。

MOD装備はそうした強力なものがかなり多いので、必要Skill値が足りないキャラでどうしてもそれらのMOD装備をしたい場合は、攻撃力や防御力をCSでVanilla装備並に下げてください。

Blade(剣) & Blunt(鈍器)の条件


・武器の重さと同等のStrength。

・武器の攻撃力に見合うBlade/ Blunt Skill。

短剣系は重さ・攻撃力が低いため、どんなキャラでも扱うことができる武器として使えます。

Bow(弓)の条件


・弓の重さ x 2のStrength。
・弓の攻撃力に見合うMarksman Skill。

弓も結構Strengthを必要としますが、これは弓の弦を引くために必要な力を加味しているそうです。
そのため弓で戦う盗賊/暗殺キャラもある程度Strengthが必要になります。

Staff(杖)の条件


・Intelligence 60 & Willpower 60

Heavy Armor(重装)の条件


・重さに見合うEndurance。
・ARに見合うHeavy Armor Skill。

Light Armor(軽装)の条件


・重さに見合うSpeed。
・ARに見合うLight Armor Skill。

Speedは他の条件と比べて必要値が低く、55あればどんな重さの軽装も条件を満たせます。

Enchant Item


エンチャントがかかった武具は必要Skillが+10されます。

Comments:2

一通 URL 2009-10-26 (月) 17:42

初めまして、いつも記事を参考にさせてもらっています。
修正パッチ頂きました。ありがたく使わせてもらいます。

Requirementsは好きなMODなんですが、ただの服が軽装扱いらしいのが玉に瑕なんですよね……自分はRealistic Levelingと併用してるのですが、新キャラで始めたらいきなり服をひん剥かれて笑ってしまいました。
他にもメイジなのに召喚武具がスキル不足で使えなかったりとかちょっとした不満があったりします。
まぁそれでも強力な武具が使えるようになった時の感動があるので、自分で手を加えてスクリプトの容量と格闘してますw

Airscape URL 2009-10-26 (月) 20:40

一通さん初めまして。
どうもエンチャントが付いていると必要Skillが一律で+10されるために、エンチャント衣服にもLight Armor Skillが必要になってしまうみたいですね。
そういった物や召喚武具は制限から除外できるといいんですが、現在のScriptが限界ぎりぎりのサイズなので条件式を増やすのが難しい感じですよね。後は装備が解除される時のメッセージをもっと簡略化して容量を減らすくらいでしょうか。

Comment Form

Trackback+Pingback:0

TrackBack URL for this entry
http://oblivionclarity.blog21.fc2.com/tb.php/128-9a168799
Listed below are links to weblogs that reference
「Da Mages Requirements」装備条件が付くMOD from Oblivion Clarity

Home > MOD紹介 > 「Da Mages Requirements」装備条件が付くMOD

Recent Comments
Recent Trackback
Search
Meta
Linkについて

トップ・各ページへのリンクはご自由にどうぞ。

Feeds

Page Top

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。